GlobalSign disables support for TLS 1.0 and 1.1
Author: 
Günther Imbrechts

The protocol support for TLS 1.0 and 1.1 will be disabled on 21st of June 2018.

What should I do?

You should do two things:

  • Verify your websites: check if the following protocols are disabled: TLS 1.0, 1.1 and also SSLv2 and SSLv3
  • Verify your browsers. Most recent browsers support TLS 1.2 or higher:
    • Google Chrome: version 30 or higher
    • Mozilla Firefox: version 27 or higher
    • MS Internet Explorer: version 11 or Edge
    • Apple Safari: version 6 and higher (mobile version 7 and higher)

You can verify your website configuration with this SSL checker: https://globalsign.ssllabs.com/

Please contact EASI if you have further questions.
 

Newsletter